PHP is amongst the most widely used multi-paradigm programming languages. It is quite popular because it’s free software, which you can use to set up interactive websites like community web portals, online shopping portals or e-learning portals rather than static HTML sites. A PHP module must be present on the web server where a PHP-driven website is hosted so that its PHP code can be ‘translated’. As there are no license fees for this sort of module and the language provides countless options for the web-based applications that you develop, there’re hundreds of millions of PHP websites. Additionally, there’re tons of PHP-based scripts, which you can use for your websites without the need to possess any programming capabilities. Since there are a number of PHP versions, you need to confirm whether the same version that you used while setting up your website is activated on the server as well.
PHP 4 and PHP 5 Support in Shared Website Hosting
Our shared website hosting servers support several PHP versions, so your sites will run without any problems no matter if your scripts are outdated. We realize that an old website does not invariably imply a vulnerable one as you may have done plenty of source code modifications. That is why we support PHP 5.5, 5.4, 5.3, 5.2 and 4 and you can pick which version will be enabled for your web hosting account. The version can be changed with only one click via your Hepsia Control Panel and the new settings will be applied instantly. In case you’d like to run both older and newer scripts, there’s even an option to use a different version of PHP for each of your domain names at the same time.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
Even if your websites were built with an older PHP version, you will be able to host them in a semi-dedicated server account from us, as we support multiple versions running simultaneously on our semi-dedicated servers and each one of them can be activated for your account with no more than one click from our custom-created Hepsia hosting Control Panel. Aside from the newest PHP 5.5 and PHP 5.4, we also offer 5.3, 5.2 and the older PHP 4, which has already been dropped by the vast majority of web hosting suppliers, but we strongly believe that you shouldn’t be forced to modify a site that took years to build, as older programming language syntax does not automatically equal security holes. Just the opposite, an adequately maintained website using PHP 4 can be more reliable than an improperly maintained one using PHP 5. For your convenience’s sake, we’ll also offer you the possibility to set a different version for each single website within your account.